Sysinternals Homepage
Forum Home Forum Home > Sysinternals Utilities > BgInfo
  New Posts New Posts RSS Feed - BGinfo at startup
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

BGinfo at startup

 Post Reply Post Reply Page  12>
Author
Message
hstiles View Drop Down
Newbie
Newbie


Joined: 06 November 2005
Location: United States
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote hstiles Quote  Post ReplyReply Direct Link To This Post Topic: BGinfo at startup
    Posted: 06 November 2005 at 8:06pm

I want to use bginfo and place it in the startup to update the information at logon.  I placed bginfo.exe and the config file bgconfig.bgi at the root of C:\.  I want to set the timer to zero so it doesn't show at logon.  I do a command prompt and type in bginfo c:\bgconfig.bgi /TIMER:0 and hit enter.  I created a shortcut of bgconfg.bgi and placed it in the startup folder.  However, when I reboot or log off and back on the editor screen comes up doing it's count down.  What am I doing wrong?

Back to Top
gsfisher13 View Drop Down
Newbie
Newbie


Joined: 06 November 2005
Location: United States
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote gsfisher13 Quote  Post ReplyReply Direct Link To This Post Posted: 06 November 2005 at 9:40pm
The target for the shortcut should be: C:\Bginfo.exe bginfo.bgi /timer:0, not just bginfo.bgi.
Back to Top
JayMan View Drop Down
Newbie
Newbie


Joined: 21 November 2005
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote JayMan Quote  Post ReplyReply Direct Link To This Post Posted: 21 November 2005 at 12:42pm
Im  having the same problem and  can't seem to get  the timer:0 to stick.  I think there is some implied step Im missing here.  Any suggestion would be appreciated. 

The instructions say to type it in from the command line which Ive done and it immediately updates the snapshot but when I log out/in it still pops up the editor screen. 

I tried modifying the shortcut with the command and it would not allow it.

Obviously im not good w/cmd line stuff and am a little lost here.
Back to Top
sithlord View Drop Down
Newbie
Newbie
Avatar

Joined: 21 November 2005
Location: United States
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote sithlord Quote  Post ReplyReply Direct Link To This Post Posted: 21 November 2005 at 10:16pm

I would suggest adding your bat file to the following:

Local Computer Policy-->User Configuration-->Windows Settings-->Scripts(Logon/Logoff)-->Logon

I personally place my BGInfo directory in Windows\System32\BGInfo.

Here is what my bat file looks like:

C:\windows\system32\bginfo\bginfo /ic:\windows\system32\BGInfo\logon.bgi /timer:0

 

 

 

Back to Top
JayMan View Drop Down
Newbie
Newbie


Joined: 21 November 2005
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote JayMan Quote  Post ReplyReply Direct Link To This Post Posted: 22 November 2005 at 9:09am
Ah, it now works like a champ.  May the force be with you, Sithlord!
Back to Top
sithlord View Drop Down
Newbie
Newbie
Avatar

Joined: 21 November 2005
Location: United States
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote sithlord Quote  Post ReplyReply Direct Link To This Post Posted: 23 November 2005 at 9:35pm

No problem!

Good to here you are working.

Back to Top
Daroma View Drop Down
Newbie
Newbie


Joined: 28 November 2005
Location: Netherlands
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Daroma Quote  Post ReplyReply Direct Link To This Post Posted: 28 November 2005 at 9:57am
If you want to skip working with batchfiles you also might try this:

-) place the BgInfo.exe and the logon.bgi in the
C:\windows\system32\bginfo\ directory

-) Then open Regedit or Regedt32.
-) Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion \Run
-) Make a new String value (REG_SZ) and name it BgInfo.
-) In the Value Data: C:\windows\system32\bginfo\BgInfo.exe C:\windows\system32\bginfo\logon.bgi /TIMER:0

-) Thats it! Now you don't see the Batch Pop-up...

I've implemented it on many servers and it works great.

Hope You can use it.

Greetz Daroma
Back to Top
BoJlk View Drop Down
Newbie
Newbie
Avatar

Joined: 16 June 2005
Location: Russian Federation
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote BoJlk Quote  Post ReplyReply Direct Link To This Post Posted: 11 December 2005 at 5:03am

The *.bat file as a logon scripts is a huge idea.
Registry is mostly used and efficient too.

Back to Top
PEJA-SE View Drop Down
Newbie
Newbie
Avatar

Joined: 15 June 2015
Location: KLOCKRIKE
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote PEJA-SE Quote  Post ReplyReply Direct Link To This Post Posted: 15 June 2015 at 9:58am
I have the following fixed:

• Edited HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
• String value (REG_SZ) and named: BgInfo.
• With the Data value: C:\BgInfo.exe C:\rainfo.bgi /TIMER:0

My problem is:
The BGInfo.bmp file is saved in the %temp% directory and that a script empties this folder at every login.

1. Is there any way to change the directory where the BGInfo.bmp file is saved to
2. Is there any way to autoupdate the BGInfo.bmp up on change of the desktop background
 
Looking forward to reply on these two issues.
 

 
//Peter

It requires a whole new way of thinking to solve the
problems we created with the old way of thinking.
Back to Top
PEJA-SE View Drop Down
Newbie
Newbie
Avatar

Joined: 15 June 2015
Location: KLOCKRIKE
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote PEJA-SE Quote  Post ReplyReply Direct Link To This Post Posted: 15 June 2015 at 1:44pm
Originally posted by Daroma Daroma wrote:

If you want to skip working with batchfiles you also might try this:

-) place the BgInfo.exe and the logon.bgi in the
C:\windows\system32\bginfo\ directory

-) Then open Regedit or Regedt32.
-) Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion \Run
-) Make a new String value (REG_SZ) and name it BgInfo.
-) In the Value Data: C:\windows\system32\bginfo\BgInfo.exe C:\windows\system32\bginfo\logon.bgi /TIMER:0

-) Thats it! Now you don't see the Batch Pop-up...

I've implemented it on many servers and it works great.

Hope You can use it.

Greetz Daroma
 
I have tried this solution, but I can see that it Loads the rainfo.bgi file to the background
unfortunately only for a few seconds before it reverts to the default background. Unhappy

There is no policy that doesn't allow changing the desktop.

At first I thought it was my script that deletes all files and folders in the %TEM% directory, but when
I disable that the problem persists.

I'm running this on a Windows 7 Pro system.
 
//Peter

It requires a whole new way of thinking to solve the
problems we created with the old way of thinking.
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.04
Copyright ©2001-2015 Web Wiz Ltd.