Sysinternals Homepage
Forum Home Forum Home > Sysinternals Utilities > BgInfo
  New Posts New Posts RSS Feed - BGINFO on Windows 7
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

BGINFO on Windows 7

 Post Reply Post Reply Page  12>
Author
Message
davidy View Drop Down
Newbie
Newbie


Joined: 21 March 2012
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote davidy Quote  Post ReplyReply Direct Link To This Post Topic: BGINFO on Windows 7
    Posted: 21 March 2012 at 7:42pm
I have a custom bginfo that worked perfectly under XP.  When a user logged in, it was automatically started for the user and displayed an icon in the taskbar.  Command used:

c:\windows\bginfo c:\windows\bginfo.bgi /taskbar

We're preparing for a Windows 7 rollout.  We're trying to get it to start the same way in Windows 7. It does launch and puts an icon in the taskbar, but it ALWAYS displays a popup dialog and beeps once even though /popup is NOT used.  I've move all files to another folder outside of C:\Windows thinking it might be a permissions problem, but the beep always occurs with the /taskbar command line option.  If I execute:

c:\tmp\bginfo c:\tmp\bginfo.bgi /nolicprompt /silent /popup

It does not beep.  It's only the /taskbar option that causes it.  Is this a bug?

Back to Top
WindowsStar View Drop Down
Senior Member
Senior Member
Avatar

Joined: 30 June 2010
Status: Offline
Points: 617
Post Options Post Options   Thanks (0) Thanks(0)   Quote WindowsStar Quote  Post ReplyReply Direct Link To This Post Posted: 22 March 2012 at 5:36am
Try moving it to \Program Files\BGInfo. That is where we have been using it for the last year without issues. Domain, non-domain machines and standard users (less permissions). -WS
Back to Top
Ninja_Prime View Drop Down
Newbie
Newbie
Avatar

Joined: 12 March 2012
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ninja_Prime Quote  Post ReplyReply Direct Link To This Post Posted: 04 April 2012 at 6:16am
Any update?
Back to Top
dacontinent View Drop Down
Newbie
Newbie


Joined: 11 April 2012
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote dacontinent Quote  Post ReplyReply Direct Link To This Post Posted: 11 April 2012 at 6:09pm
Looking to deploy BGInfor on Win7 like I have it on XP boxes.  Parms are
<User Name>  <Snapshot Time>
<Host Name>
<IP Address>
Boot Time: <Boot Time>
Memory: <Memory>
OS Version: <OS Version>
Service Pack: <Service Pack>
Volumes: <Volumes>
 
Snapshot Time and Boot Time seem to get overlaid on the bmp starting when I logon the machine for the second time.  This does not happen on XP platform. 
 
Any clues?
DAContinent
Back to Top
Ninja_Prime View Drop Down
Newbie
Newbie
Avatar

Joined: 12 March 2012
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ninja_Prime Quote  Post ReplyReply Direct Link To This Post Posted: 20 April 2012 at 2:11pm
You can customise the the display of BGinfo by clicking on the custom tab and then select new, then play around with the settings...good luck
Back to Top
aaronmar View Drop Down
Moderator Group
Moderator Group


Joined: 13 July 2010
Status: Offline
Points: 66
Post Options Post Options   Thanks (0) Thanks(0)   Quote aaronmar Quote  Post ReplyReply Direct Link To This Post Posted: 09 October 2012 at 3:04am
/taskbar implies /popup, at least in the current version.
-- Aaron Margosis (Microsoft)
co-author of The Windows Sysinternals Administrator's Reference.
http://www.amazon.com/Windows-Sysinternals-Administrators-Reference-Russinovich/dp/073565672X
Back to Top
kfeina View Drop Down
Newbie
Newbie


Joined: 07 November 2012
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote kfeina Quote  Post ReplyReply Direct Link To This Post Posted: 19 November 2012 at 11:11pm
Hello,

Try bginfo4x: it works with windows xp, windows 7, windows 2003, .... also works with linux and MAC.

It has lots of features, more than you need.

http://bginfo4x.sourceforge.net

Regards.
Back to Top
WindowsStar View Drop Down
Senior Member
Senior Member
Avatar

Joined: 30 June 2010
Status: Offline
Points: 617
Post Options Post Options   Thanks (0) Thanks(0)   Quote WindowsStar Quote  Post ReplyReply Direct Link To This Post Posted: 21 November 2012 at 12:52am
Originally posted by kfeina kfeina wrote:

Hello,

Try bginfo4x: it works with windows xp, windows 7, windows 2003, .... also works with linux and MAC.

It has lots of features, more than you need.

http://bginfo4x.sourceforge.net

Regards.
 

Some Issues:

 

#1 Unfortunately this is way too complicated for the average user or Junior Admin.

#2 Does not support Registry, VBScript, WMI, etc.

#3 Does not work in a Domain with restrictions.

#4 Does not follow Microsoft Standards.

#5 Uses CygWin (many known issues, plus it installs off the root of C: huge no no).

 

Great project and we really thank you for making this. I think when you can overcome some of the issues  above you will have a solid program. Just my two cents, there is no flaming here. -WS

Back to Top
DHeshMan View Drop Down
Newbie
Newbie


Joined: 09 January 2013
Location: PA
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote DHeshMan Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2013 at 8:46pm
I have configured a custom settings file in Windows XP that included the IP Address and Subnet Mask.  When I moved this BGInfo and settings file to Windows 7, it put a huge blank multi-line area for these 2 fields and does not show the configured information.  I am configuring my IP Address in Windows 7 as TCP/IP v4.  Is there something else I need to do to make BGInfo show my IP Address and Subnet Mask correctly?  Currently my PC is not connected to any network, but will be at a later date.
Back to Top
DHeshMan View Drop Down
Newbie
Newbie


Joined: 09 January 2013
Location: PA
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote DHeshMan Quote  Post ReplyReply Direct Link To This Post Posted: 09 January 2013 at 8:59pm
Ok.  A little progress.  I downloaded an updated BGInfo version 4.1.3.  Now my IP Address is no longer blank, but instead is shows "(None)".  However, I have hard-coded my IP Address so it should show one.  Any ideas?
 
Thanks
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down