Sysinternals Homepage
Forum Home Forum Home > Sysinternals Utilities > Disk2vhd
  New Posts New Posts RSS Feed - Disk fails to copy on 3rd drive
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Disk fails to copy on 3rd drive

 Post Reply Post Reply
Author
Message
DavidGAus View Drop Down
Newbie
Newbie
Avatar

Joined: 23 April 2017
Location: Melbourne
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote DavidGAus Quote  Post ReplyReply Direct Link To This Post Topic: Disk fails to copy on 3rd drive
    Posted: 23 April 2017 at 1:29am
HI All,

Newbie here and new to using Sysinternals Disk2vhd to do backups. I have a the following server:

Windows 2008 R2 Server (fully patched)
Running MS SQL Server
Disk C - 930GB (89GB Used) - Creates a 63GB VHDX File
Disk D - 930GB (114GB Used)  - Creates a 77GB VHDX File
Disk E - 930GB (63GB Used)  - Creates a 70GB VHDX File
2 6 Core Xeon Processors (giving 24 Logical)
16 GB Physical Memory
Disk2vhd - Version 2.01 (dated 20/01/2014)

I use Disk2vhd to backup to a network location using a the following command:

c:\backup\disk2vhd * \\10.10.2.2\data\the_server\the_server.vhdx

Now to the issue at hand. The first 2 hard drives backup fine (Disk C & Disk D), but the third disk (Disk E) only backs up 11.2GB and then the application hangs. Not sure if it being the main MSSQL Database storage drive is relevant. I can then backup the third disk drive fine using the following: 

c:\backup\disk2vhd E: \\10.10.2.2\data\the_server\the_server-2.vhdx

Right royal pain in the backside having to manually do it everyday it fails. I did see the following in the eventvwr which I had fixed, but it is still failing on that disk drive (and I don't believe it is related to the issue):

Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface.  hr = 0x80070005, Access is denied.

The thing that is really annoying is that it will go sometimes for for a few days working fine, then it will error for a week or a day, so it doesn't make sense to me why. If anyone knows why this would happen, would appreciate information on how to over come it and fix it.

I am am going to try the following, but not the preferred method for the work around:

c:\backup\disk2vhd C: \\10.10.2.2\data\the_server\the_server-0.vhdx
c:\backup\disk2vhd D: \\10.10.2.2\data\the_server\the_server-1.vhdx
c:\backup\disk2vhd E: \\10.10.2.2\data\the_server\the_server-2.vhdx

I have another 3 servers that I do the backups this way and do not have an issue with them.

Much appreciate any help.


Edited by DavidGAus - 23 April 2017 at 1:30am
Cheers,

David G
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.