Sysinternals Homepage
Forum Home Forum Home > Sysinternals Utilities > Disk2vhd
  New Posts New Posts RSS Feed - Disk2vhd on Domain Controller not working in DSRM
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Forum LockedDisk2vhd on Domain Controller not working in DSRM

 Post Reply Post Reply
LD1 View Drop Down

Joined: 20 July 2017
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote LD1 Quote  Post ReplyReply Direct Link To This Post Topic: Disk2vhd on Domain Controller not working in DSRM
    Posted: 20 July 2017 at 10:58pm

I need to P2V some Server 2008 R2 DCs (I know not good practise, long story, have just inherited this site, can't add an additional virtual DC to the environment as there is a middleware over AD which means you cannot use AD in the normal fashion and this middleware is now unsupported so there is no way to add additional DCs at this time, we are just trying to P2V the servers off failing old hardware and keep things running for a few more months until we rebuild the environment, I am aware of the dangers of USN rollback, etc, ADDS, DFS Replication and DNS services will be disabled during P2V).

I've been testing this in lab environment, I wanted to run Disk2vhd from DSRM (Directory Services Restore Mode) but it won't run with the 'Use volume shadow copy' option ticked, it produces the 'error snapshotting volumes' error (even though the Volume Shadow Copy service is started in DSRM).

So I tried it from Safe Mode instead, here I had to manually disable the ADDS service as this was still running (unlike in DSRM), however in safe mode it produces a Visual C++ Runtime Error, which some people have said you need to enable the Volume Shadow Copy service to fix, however this cannot be enabled in safe mode.

I would like to get it to work in DSRM if anyone knows how, however as long as I am careful with the services, replication, old physical server, etc, should I just do it from a normal boot (as this works fine)?

EDIT: Actually it doesn't work fine during a normal boot, I still get the C++ runtime error, maybe I need windows updates on my test machine.

Edited by LD1 - 20 July 2017 at 11:12pm
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.