Sysinternals Homepage
Forum Home Forum Home > Windows Discussions > Troubleshooting
  New Posts New Posts RSS Feed - Need help with Ntoskrnl thread causing high CPU
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Need help with Ntoskrnl thread causing high CPU

 Post Reply Post Reply Page  <1 888990
Author
Message
 Rating: Topic Rating: 1 Votes, Average 5.00  Topic Search Topic Search  Topic Options Topic Options
MagicAndre1981 View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 08 January 2007
Location: Germany
Status: Offline
Points: 3472
Post Options Post Options   Thanks (0) Thanks(0)   Quote MagicAndre1981 Quote  Post ReplyReply Direct Link To This Post Posted: 08 February 2018 at 7:07pm
Originally posted by Fabio465 Fabio465 wrote:

@MagicAndre1981
AS many other have done over the years, I'm also asking you for help about the "system" process taking up a lot of my CPU (25%). USing process Explorer I found out that this is the faulty thread --> "ntoskrnl.exe!ExQueryDepthSList+0x158.


I only see ndis.sys as cause. I see you use VPNs, try to remove it and also update all network related code/drivers
Back to Top
mtsivert View Drop Down
Newbie
Newbie


Joined: 13 February 2018
Location: Norway
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote mtsivert Quote  Post ReplyReply Direct Link To This Post Posted: 13 February 2018 at 10:15pm
@MagicAndre1981 - Could you please help me as well? I've sent you a PM with link to the file.
Having the same issue with ntoskrnl on Windows Server 2016.


Edited by mtsivert - 14 February 2018 at 12:41pm
Back to Top
MagicAndre1981 View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 08 January 2007
Location: Germany
Status: Offline
Points: 3472
Post Options Post Options   Thanks (0) Thanks(0)   Quote MagicAndre1981 Quote  Post ReplyReply Direct Link To This Post Posted: 14 February 2018 at 4:19pm
Originally posted by mtsivert mtsivert wrote:

Having the same issue with ntoskrnl on Windows Server 2016.

I see hal.dll!HalpMcaReportError in stack, so look in event log with Machine Check Architecture/MCA Errors get logged. 
Back to Top
Torki View Drop Down
Newbie
Newbie


Joined: 18 February 2018
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Torki Quote  Post ReplyReply Direct Link To This Post Posted: 18 February 2018 at 1:38pm
Hello !

I too suffer from the high cpu usage by the system process.. 
And this looks like THE place to be to get it sorted out !
Here is the xperf  file :  https://drive.google.com/file/d/1_DLSVwTOiRMFaMnOW6kjKg6EpDmUUDui/view?usp=sharing

I really hope you can give me a hand in sorting this out MagicAndre !!
Back to Top
MagicAndre1981 View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 08 January 2007
Location: Germany
Status: Offline
Points: 3472
Post Options Post Options   Thanks (0) Thanks(0)   Quote MagicAndre1981 Quote  Post ReplyReply Direct Link To This Post Posted: 19 February 2018 at 3:45pm
Originally posted by Torki Torki wrote:

I really hope you can give me a hand in sorting this out MagicAndre !!

This causes the high CPU usage:

Line #DPC/ISRProcessStack TagStackCountTimeStamp% Weight
10  |    |    |- ndis.sys!ndisCloseMiniportBindingsForPause1838113,18
11  |    |    |    |- ntoskrnl.exe!KeAcquireSpinLockAtDpcLevel110967,96

ndis.sys is networking component. So update all network card drivers and software. 

Your Linksys WUSB6300 driver rtwlanu.sys is version "1030.17.1101.2016, last version is 1030.19.0103.2017

Back to Top
 Post Reply Post Reply Page  <1 888990
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.