Sysinternals Homepage
Forum Home Forum Home > Sysinternals Utilities > Process Explorer
  New Posts New Posts RSS Feed - ** Process Explorer Bugs **
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

** Process Explorer Bugs **

 Post Reply Post Reply Page  123 84>
Author
Message
EP_X0FF View Drop Down
Senior Member
Senior Member
Avatar

Joined: 08 March 2006
Location: Russian Federation
Status: Offline
Points: 4758
Post Options Post Options   Thanks (1) Thanks(1)   Quote EP_X0FF Quote  Post ReplyReply Direct Link To This Post Topic: ** Process Explorer Bugs **
    Posted: 15 June 2006 at 7:49am
-Process Explorer v10.11 Bugs-


This version is very stable but I still see some "bugs" inside .

1)System Idle Process security issue This quasi process has "Session -1" in properties->security tab, I don't think that such session exists.

2)Run As strange handling After I selected some process to start I must select from which user account it must be started. However if I press "Cancel" in this dialog, PE told me "Unable to execute process: Access Denied". Well I guess it must simple do nothing in this case.

3)IsDebuggerPresent function statically linked, so Process Explorer can't start on Windows 95. Whole operation system is not supported.

4)Save As non existing process strange handling
When I select some process from list and press "Save As", save dialog is opening. In this moment selected process is ending and removing from Process Explorer list. However when I press "Ok" in Save Dialog PE saves text file on disk. Inside the log I see name of dead process with PID of Process Explorer and all objects displayed here is also Process Explorer objects.

Opera.exe     3836 ;       Opera Internet Browser     Off   &n bsp;C:\Program Files\Opera\Opera.exe     MAINFRAME 64\EP_X0FF     Running
procexp.exe     3424&nb sp;13.04     Sysinterna ls Process Explorer     On   &n bsp;C:\Program Files\WIN2000\procexp.exe      MAINFRAME64\EP_X0FF ;   Running

Process: calc.exe Pid: 3424

Type     Name   &nbs p;Share Flags
Desktop     \Default&nb sp;
Directory     \KnownDlls ;   
Directory     \Windows& nbsp;
Directory     \BaseNamedObjects&nbs p;    
Event     \BaseNamedObjects\CLR_Per fMon_DoneEnumEvent     
Event     \BaseNamedObjects\CLR_Per fMon_StartEnumEvent     
Event     \BaseNamedObjects\crypt32 LogoffEvent     
Event     \BaseNamedObjects\Microso ft Smart Card Resource Manager Started     
Event     \BaseNamedObjects\userenv : User Profile setup event     


5)Find Handle or DLL restriction
Process Explorer can't find DLL located in SYSTEM context.

6)Empty Window Title cannot be found by PE. If Windows has empty title - "Window" element is not active in context menu of Process Explorer. But I see no reasons why Process Explorer can't operate with empty titled visible top level windows.

Hope this bugs will be fixed in next release.

Kind Regards.

EDIT: Changed topic title

Edited by EP_X0FF - 29 August 2006 at 3:39am
Back to Top
vyach View Drop Down
Newbie
Newbie


Joined: 16 June 2006
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote vyach Quote  Post ReplyReply Direct Link To This Post Posted: 16 June 2006 at 8:56am

One More.

 When I try to get to my PC by using Remote Desktop and there is the Process Explorer running all I get is a blank screen with no menus, icons etc

Back to Top
ivan View Drop Down
Senior Member
Senior Member
Avatar

Joined: 04 June 2005
Location: Slovenia
Status: Offline
Points: 189
Post Options Post Options   Thanks (0) Thanks(0)   Quote ivan Quote  Post ReplyReply Direct Link To This Post Posted: 18 June 2006 at 4:06pm
And there is also the one that I've described in the PEs UI glitch on process opening/closing thread (but I guess only for some users), and maybe also this one: Specific Process Explorer crashes ...


cheers, Ivan

My personal homepage: http://tadej-ivan.50webs.com/, please visit it and enjoy in my computing-related discoveries, hints, principles, and rules.
Back to Top
EP_X0FF View Drop Down
Senior Member
Senior Member
Avatar

Joined: 08 March 2006
Location: Russian Federation
Status: Offline
Points: 4758
Post Options Post Options   Thanks (0) Thanks(0)   Quote EP_X0FF Quote  Post ReplyReply Direct Link To This Post Posted: 18 June 2006 at 10:24pm
Just one thing.

7)Process Explorer settings

Can Process Explorer check settings version in Registry and if they are old - remove them? This can avoid many bugs with oldest settings.

Edited by EP_X0FF - 21 June 2006 at 3:40am
Back to Top
deadfones View Drop Down
Newbie
Newbie


Joined: 16 May 2006
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote deadfones Quote  Post ReplyReply Direct Link To This Post Posted: 19 June 2006 at 10:13pm
I'll repost this here.

Proc property windows keep migrating left

My taskbar's on the left, and after opening and closing a few process properties windows, they've migrated so far left I can only move them with an alt+space.  Not that it actually gets to that point, because I drag the window towards the center after opening a window, each time.

I recorded the window's x, y after each closing/opening/closing etc on csrss.exe and they are as follows:
600, 215
348, 215
96, 215
-156, 215
-408, 215

So they're jumping left 252 pixels, which unsurprisingly is the same width as my taskbar.  Other dialogs are not affected by this.

This doesn't happen if my taskbar's on the bottom.  I'm using 10.11.

===

Verified by http://www.sysinternals.com/Forum/forum_posts.asp?TID=5972&a mp;KW=deadfones
Back to Top
EP_X0FF View Drop Down
Senior Member
Senior Member
Avatar

Joined: 08 March 2006
Location: Russian Federation
Status: Offline
Points: 4758
Post Options Post Options   Thanks (0) Thanks(0)   Quote EP_X0FF Quote  Post ReplyReply Direct Link To This Post Posted: 20 June 2006 at 11:40pm
Further discovering of Process Explorer v10.11 Save As bugs shown following:

8)PE Save As+Process Terminate bug

if PE is paused and selected process is terminated with PE this feature also fails, like in first post.

It is not displaying objects, but the same
Process: Procexp Pid: PidOfTheDeadProcess

Will post here if I find something else.
Back to Top
redhawk View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 14 September 2005
Location: United Kingdom
Status: Offline
Points: 1362
Post Options Post Options   Thanks (0) Thanks(0)   Quote redhawk Quote  Post ReplyReply Direct Link To This Post Posted: 21 June 2006 at 3:57am
The lower view panel when resized and dropped falls above the current mouse position. This bug has been present in version 9.25, reported and not fixed.
Using Find Handle / DLL, column sorting "Type" doesn't group all Handles and DLL correctly one or two overlap each other.
Corrupted exe version info crashes Process Explorer running on Windows 9x.

Richard S.


Edited by redhawk - 21 June 2006 at 4:03am
Back to Top
EP_X0FF View Drop Down
Senior Member
Senior Member
Avatar

Joined: 08 March 2006
Location: Russian Federation
Status: Offline
Points: 4758
Post Options Post Options   Thanks (0) Thanks(0)   Quote EP_X0FF Quote  Post ReplyReply Direct Link To This Post Posted: 21 June 2006 at 3:59am
9)"Debug" feature not working under Win98
Well, I guess this should attach debugger to selected process. I tried many times - no luck, perhaps I doing something wrong, what debugger should be attached under Windows 98? DrWatson? Could someone explain me?

10)Pause not "pause" bug
This bug succesfully reproduced under Windows 98 and Windows XP SP2, I guess it's working everywhere.

Steps to reproduce:
1) Press "Space" to pause display refreshing
2) Ctrl+F to find handle or DLL, you can also use menu.
3) You can type anything and press search or simple press cancel - that works identically.
4) List will be refreshed for a second then again paused.
I think if I press "Pause" then PE should pause display refresh for all time, even if I search for something.

11)Shutdown works like "LogOff" under Windows 98
Yep, exactly this. Pressing logoff - doing logoff, pressing shutdown - ...doing logoff, or I miss something?

I will continue my discovery.
Back to Top
redhawk View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 14 September 2005
Location: United Kingdom
Status: Offline
Points: 1362
Post Options Post Options   Thanks (0) Thanks(0)   Quote redhawk Quote  Post ReplyReply Direct Link To This Post Posted: 11 July 2006 at 5:55pm
Originally posted by redhawk redhawk wrote:

The lower view panel when resized and dropped falls above the current mouse position. This bug has been present in version 9.25, reported and not fixed.
Using Find Handle / DLL, column sorting "Type" doesn't group all Handles and DLL correctly one or two overlap each other.
Corrupted exe version info crashes Process Explorer running on Windows 9x.

Richard S.


I've download Process Explorer 10.2 and this problem still exists. In fact I believe it's not sorting correctly because clicking on the "Type" column is actually sorting the "Handles or DLL" column instead.

Support for Windows95 is still broken thanks to IsDebuggerPresent dependency (unless you apply a dirty hack).

Richard S.


Edited by redhawk - 11 July 2006 at 6:11pm
Back to Top
EP_X0FF View Drop Down
Senior Member
Senior Member
Avatar

Joined: 08 March 2006
Location: Russian Federation
Status: Offline
Points: 4758
Post Options Post Options   Thanks (0) Thanks(0)   Quote EP_X0FF Quote  Post ReplyReply Direct Link To This Post Posted: 11 July 2006 at 7:40pm
-Process Explorer v10.2 Bugs-


Originally posted by EP_X0FF EP_X0FF wrote:

1)System Idle Process security issue This quasi process has "Session -1" in properties->security tab, I don't think that such session exists.


--fixed, n/a

Originally posted by EP_X0FF EP_X0FF wrote:

2)Run As strange handling After I selected some process to start I must select from which user account it must be started. However if I press "Cancel" in this dialog, PE told me "Unable to execute process: Access Denied". Well I guess it must simple do nothing in this case.


--not fixed

Originally posted by EP_X0FF EP_X0FF wrote:

3)IsDebuggerPresent function statically linked, so Process Explorer can't start on Windows 95. Whole operation system is not supported.


--not fixed

Originally posted by EP_X0FF EP_X0FF wrote:

4)Save As non existing process strange handling
When I select some process from list and press "Save As", save dialog is opening. In this moment selected process is ending and removing from Process Explorer list. However when I press "Ok" in Save Dialog PE saves text file on disk. Inside the log I see name of dead process with PID of Process Explorer and all objects displayed here is also Process Explorer objects.


--fixed, as I can see right now

Originally posted by EP_X0FF EP_X0FF wrote:

5)Find Handle or DLL restriction
Process Explorer can't find DLL located in SYSTEM context.


--not fixed

Originally posted by EP_X0FF EP_X0FF wrote:

6)Empty Window Title cannot be found by PE. If Windows has empty title - "Window" element is not active in context menu of Process Explorer. But I see no reasons why Process Explorer can't operate with empty titled visible top level windows.


--not fixed

Originally posted by EP_X0FF EP_X0FF wrote:

8)PE Save As+Process Terminate bug

if PE is paused and selected process is terminated with PE this feature also fails, like in first post.

It is not displaying objects, but the same
Process: Procexp Pid: PidOfTheDeadProcess


--fixed as I see right now

Originally posted by EP_X0FF EP_X0FF wrote:

10)Pause not "pause" bug
This bug succesfully reproduced under Windows 98 and Windows XP SP2, I guess it's working everywhere.

Steps to reproduce:
1) Press "Space" to pause display refreshing
2) Ctrl+F to find handle or DLL, you can also use menu.
3) You can type anything and press search or simple press cancel - that works identically.
4) List will be refreshed for a second then again paused.
I think if I press "Pause" then PE should pause display refresh for all time, even if I search for something.


--not fixed


Originally posted by EP_X0FF EP_X0FF wrote:

11)Shutdown works like "LogOff" under Windows 98
Yep, exactly this. Pressing logoff - doing logoff, pressing shutdown - ...doing logoff


--not fixed still shutdown=logoff

New Discovered Bugs in Process Explorer v10.2


1)[System Process] bug

1) Ctrl+F, type ntdll.dll
2) In list of dll you can see ntdll.dll that used by [System Process] with Process Explorer pid.

Edited by EP_X0FF - 11 July 2006 at 8:37pm
Back to Top
 Post Reply Post Reply Page  123 84>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.