Sysinternals Homepage
Forum Home Forum Home > Sysinternals Utilities > Miscellaneous Utilities
  New Posts New Posts RSS Feed - Robocopy - won't copy only newer files
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Robocopy - won't copy only newer files

 Post Reply Post Reply
wanttohike View Drop Down

Joined: 11 December 2012
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote wanttohike Quote  Post ReplyReply Direct Link To This Post Topic: Robocopy - won't copy only newer files
    Posted: 11 December 2012 at 10:45pm
Hi, I am trying to configure Robocopy to backup all the files from my home computer "My Documents" and my work computer's "My Documents" to the same external hard drive that I carry back and forth from home to work--plus, I'd like to copy over all my kid's documents too. I've been using xcopy for years and it's worked great but when I upgraded my MS software, it stopped working. Supposedly, robocopy can do it too, but it's giving me problems.
For some reason, Robocopy is copying over all the files with every backup. Since I have a ton of files, it takes several hours per computer. My old batch file with xcopy took only a few minutes because I was able to configure the switches to only copy new files. I'm trying to find a way to have robocopy copy just the new files into my backup directory.
- I don't want to use the /mir switch because I'm copying several computers to the same destination and the /mir switch will delete files it does not recognize from the source directory.
- I've tried the /fft swtich, but it's not working. Still robocopy copies all the files.
Here's what I'm putting into my batch file:
robocopy c:\users\home\Documents "J:\\backup\My Documents" /xo /fft /xj /Copyall /E /R:1
For troubleshooting purposes, I also wrote it with just the /mir switch and it likewise copied all files, not just the newer ones. Likewise, I also tried the /a /m switches too, but they didn't help.
Can you help me with what I'm missing? Perhaps another backup software that I can create into a batch file?
Thanks much.
Back to Top
user147 View Drop Down

Joined: 22 April 2013
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote user147 Quote  Post ReplyReply Direct Link To This Post Posted: 22 April 2013 at 10:56pm

I can reproduce your problem when copying data from NTFS to FAT32 filesystems. I'm using robocopy which comes with Windows 8 but it probably does also apply for previous OS's where robocopy comes also with the OS.
From my perspective the robocopy versions which comes with the OS are unfortunately rather buggy. Options like /FAT or copying NTFS security are not working correctly anymore and this problem is likely another bug.

I checked and when using the older XP010 version of robocopy this problem won't occur. This version is part of the "Windows Server 2003 Resource Kit Tools" and can be downloaded here.

If you have an unzip utility like 7-Zip ( then you do not have to install this and you can unpack the exe first. Then open the rktools.msi with 7-Zip and extract robocopy.doc and robocopy.exe.

To avoid confusion with the OS version of robocopy and if you prefer you can rename "robocopy.exe" to e.g. "robocopy010.exe" and place it in the directory of the batch file.

Lastly, if you are indeed copying from NTFS to FAT32 then you might want to leave out the parameter /COPYALL as /E already copies Data, Attributes and Timestamps and you can't copy Security, Ownership info and Auditing info while copying from NTFS to FAT32.



Back to Top
Patrick8 View Drop Down

Joined: 26 December 2014
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Patrick8 Quote  Post ReplyReply Direct Link To This Post Posted: 26 December 2014 at 1:56pm
I suggest to try "Long Path Tool" program .
trust me it work, bro :). may can help u :)
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.