Sysinternals Homepage
Forum Home Forum Home > Sysinternals Utilities > Process Monitor
  New Posts New Posts RSS Feed - Running Procmon from CygWin
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Running Procmon from CygWin

 Post Reply Post Reply
cbodels View Drop Down

Joined: 09 March 2018
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote cbodels Quote  Post ReplyReply Direct Link To This Post Topic: Running Procmon from CygWin
    Posted: 09 March 2018 at 6:32pm
Hi all,

I'm having some trouble running process monitor from an automated script on an ubuntu machine. 

The current setup is that I have an ubuntu machine with a script which SSH's into a Windows 7 machine using CygWin on the windows machine. The SSH command in the script attempts to invoke a Powershell script on the Windows machine which then starts process monitor but no matter how I do it I cannot get it to work from the script.

The problem appears to stem from having the SSH command with the powershell call all on one line because if I do it manually all one line it doesn't work but if I just use SSH to login to the Windows machine via Cygwin and then once logged in do "powershell ./test.ps1" it works perfectly.

I am really not sure what is causing this problem so any help would be greatly appreciated. And I apologise if this is more of a Cygwin question but there doesn't seem to be a particularly active forum for that so I thought I would try my luck here to see if you guys might have any suggestions. 

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.