Sysinternals Homepage
Forum Home Forum Home > Sysinternals Utilities > Miscellaneous Utilities
  New Posts New Posts RSS Feed - SDelete hangs at 100%
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

SDelete hangs at 100%

 Post Reply Post Reply Page  <12
Author
Message
dinno73 View Drop Down
Newbie
Newbie
Avatar

Joined: 18 October 2016
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote dinno73 Quote  Post ReplyReply Direct Link To This Post Posted: 18 October 2016 at 11:10am
i've v2 and after 3 hours It is still 100%
what's name of the temporary file?
Back to Top
sndp_and View Drop Down
Newbie
Newbie


Joined: 24 December 2016
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote sndp_and Quote  Post ReplyReply Direct Link To This Post Posted: 24 December 2016 at 4:24am
Hi,

I am facing the same issue while building my virtualbox build using packer tool. Earlier it used to work fast but now it just hangs for ever at Sdelete command. Can you please tell me where can I check the version of sdelete command and how to replace it?
at the command prompt it shows:

virtualbox-iso: C:\Users\vagrant>cmd /c C:\Windows\Temp\sdelete.exe -q -z C:
    virtualbox-iso:
    virtualbox-iso: SDelete v2.0 - Secure file delete
    virtualbox-iso: Copyright (C) 1999-2016 Mark Russinovich
    virtualbox-iso: Sysinternals - www.sysinternals.com
    virtualbox-iso:
    virtualbox-iso: SDelete is set for 1 pass.

but there is no such application called sdelete at \windows\temp path. Or is it located internally in the virtual machine being built up? how can I replace it with older version.
Please help, if you have been able to resolve this issue.

thanks
Back to Top
MRBW View Drop Down
Newbie
Newbie


Joined: 31 December 2016
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote MRBW Quote  Post ReplyReply Direct Link To This Post Posted: 31 December 2016 at 11:49am
Could you please make the previous version available for download until you solve this issue....please :-)
Back to Top
MRBW View Drop Down
Newbie
Newbie


Joined: 31 December 2016
Status: Offline
Points: 7
Post Options Post Options   Thanks (1) Thanks(1)   Quote MRBW Quote  Post ReplyReply Direct Link To This Post Posted: 31 December 2016 at 11:56am
Luckely I found version 1.61 in one of my old virtual machines.
I uploaded to my web-server for others:
http://www.wit.dk/temp/sdelete_1.61.0.0.exe

Back to Top
MagicAndre1981 View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 08 January 2007
Location: Germany
Status: Offline
Points: 3404
Post Options Post Options   Thanks (0) Thanks(0)   Quote MagicAndre1981 Quote  Post ReplyReply Direct Link To This Post Posted: 07 January 2017 at 12:33pm
I already wrote a mail to Mark, but I have no idea if he already started working on this issue.
Back to Top
charlatan View Drop Down
Newbie
Newbie


Joined: 15 January 2017
Location: Australia
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote charlatan Quote  Post ReplyReply Direct Link To This Post Posted: 15 January 2017 at 9:49pm
Used SDelete 2.0 (32-bit) on Windows 7 64-bit, to clear 4.2 GB empty space on a WD My Book Duo 16 TB over USB 3.0.

D:\Download\SDelete>sdelete -c l:

SDelete v2.0 - Secure file delete
Copyright (C) 1999-2016 Mark Russinovich
Sysinternals - www.sysinternals.com

SDelete is set for 1 pass.
Cleaning free space on L:\: 100%^C


Took about 28 hours to reach 100%. It remained at 100% for about about six hours until I Ctrl-C'ed out. Oddly, the noise level from the drive was greater throughout this 100% phase. There wasn't any hidden temp file left over.

Not sure if this is of any relevance, but I'd previously interrupted it at around 10% with Ctrl-C as it was taking longer than anticipated, and didn't delete the temporary file (if there was one left over)
Back to Top
Rob Nicholson View Drop Down
Newbie
Newbie


Joined: 17 January 2017
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Rob Nicholson Quote  Post ReplyReply Direct Link To This Post Posted: 17 January 2017 at 6:03pm
I assume the reference to v1.66 above is a typo and the previous version was v1.61?
Back to Top
davidski View Drop Down
Newbie
Newbie


Joined: 06 March 2017
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote davidski Quote  Post ReplyReply Direct Link To This Post Posted: 06 March 2017 at 10:41pm
Has anyone heard any updates of getting a fixed version of SDelete 2.0 published, or getting 1.0 published officially while a fix is in progress? Sdelete is used in a lot of Packer workflows for building Windows boxes for Vagrant and other platforms. Having this broken is awfully inconvenient.

David
Back to Top
WhiteX View Drop Down
Newbie
Newbie


Joined: 26 June 2017
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote WhiteX Quote  Post ReplyReply Direct Link To This Post Posted: 26 June 2017 at 1:18pm
Update: tried this on 26/06 and still having the same issues as described above. 
It's a shame this doesn't get any attention while being reported several times.
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.