Sysinternals Homepage
Forum Home Forum Home > Sysinternals Utilities > Disk2vhd
  New Posts New Posts RSS Feed - Unable to boot converted VHDX
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Unable to boot converted VHDX

 Post Reply Post Reply
arjunvyavahare View Drop Down

Joined: 11 July 2008
Location: India
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote arjunvyavahare Quote  Post ReplyReply Direct Link To This Post Topic: Unable to boot converted VHDX
    Posted: 01 September 2016 at 5:44am


We have one laptop which we have convereted into VHDX and when we attach VHDX to our Hyper-V 2012 Server we are not able to boot the converted machine and getting following error -

"Boot Failed. EFI SCSCI Device"

Tool used to convert physical machine to virtusl is - Disk2VHD (Microsoft Disk2VHD

error msg.

We have selected the Generation 2 option and also unchecked the Enable Secure Boot option but still getting this error message.

Please note that we don't want to boot from ISO we want to boot this VHDX, please help us.

Your reply is highly appreciated.

Back to Top
ewgoforth View Drop Down

Joined: 25 October 2006
Status: Offline
Points: 35
Post Options Post Options   Thanks (0) Thanks(0)   Quote ewgoforth Quote  Post ReplyReply Direct Link To This Post Posted: 18 October 2016 at 7:54pm
I'm having the same problem. Did you get a solution?
Back to Top
rkoett View Drop Down

Joined: 27 February 2013
Status: Offline
Points: 8
Post Options Post Options   Thanks (0) Thanks(0)   Quote rkoett Quote  Post ReplyReply Direct Link To This Post Posted: 15 March 2017 at 6:24pm
I ran into a similar problem recently. In my case the problem occurred when the disk I originally imaged was initialized as GPT instead of the older MBR. This can be seen by mounting the VHDX, then running DISKPART from a command prompt and typing "list disk". (There will be a * shown under the "Gpt" column). If you then type "list volume", you may see the problem I encountered. There is a system partition (around 100MB in my case) listed as type "RAW". On the physical system this is listed as type "FAT32". The failure to properly image this partition is what caused the boot failures in my case.

If you are encountering the same problem, here are the steps I took to fix it. I would suggest making a backup copy of your VHDX file before trying these steps:

* Boot the VM from Windows install media (.ISO file)
* Select Repair your computer, Troubleshoot, Command prompt
* Run diskpart
* type "select disk 0"
* type "list partition" to get the System partition number)
* Select the System partition (e.g. type "select partition 3")
* format quick fs=fat23 label="System"
* assign letter=S
* exit
* bcdedit /createstore
* bootrec /RebuildBCD
* (type "Y" to accept the detected parameters)
* bcdboot C:\Windows /s S: /f UEFI
* Reboot the VM

As I said, these steps worked for me. There are other possible solutions I haven't tried. One suggestion I read was that temporarily assigning a drive letter to the system partition on the original disk before running disk2vhd allows it to be detected and imaged as the correct type instead of "RAW". Another approach involves converting the virtual disk from GPT format to MBR format. I have not looked into the details of how that might be done.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.